Stuttering & four stroking

Anything related to Lambrettas... ask tech questions, post helpful info, or just read and learn.
Lambretta67
registered user
Posts: 233
Joined: Fri Mar 30, 2018 5:02 pm
ebay user ID: Lambretta67
Main scooter: Lambretta L.I. 200 special
Location: Newbury
Contact:

Thu Jun 25, 2020 7:59 pm

Hi my standard G.P. 200 has started stuttering & four stroking at low revs when changing gear. I'm using a standard 22mm carb. I have to drop down a gear & give loads of revs then change up. Ticks over fine & runs fine when opened up. Any ideas please

Daggs
registered user
Posts: 706
Joined: Wed Jan 07, 2009 1:23 pm
Location: Addington Kent
Contact:

Thu Jun 25, 2020 9:08 pm

You say "started stuttering and four-stroking" Does this mean it previously ran well and this is a new thing?

Lambretta67
registered user
Posts: 233
Joined: Fri Mar 30, 2018 5:02 pm
ebay user ID: Lambretta67
Main scooter: Lambretta L.I. 200 special
Location: Newbury
Contact:

Thu Jun 25, 2020 9:27 pm

When I first got the scoot 5yrs ago it started doing the same thing. I changed the dellorto atomizer for a jetex one of the same size & it seemed to cure it. Have done about 6000 miles on it with no problem but now it's back with a vengeance. It's a original 22mm dellorto carb I'm using so its it's probably a bit worn.

User avatar
EddieStone
registered user
Posts: 413
Joined: Mon Aug 17, 2015 4:13 pm
Main scooter: Lambretta Li 150
Contact:

Thu Jun 25, 2020 10:15 pm

Could be a leaky needle/float valve. Atomisers don't wear in these carbs, to be honest.

Lambretta67
registered user
Posts: 233
Joined: Fri Mar 30, 2018 5:02 pm
ebay user ID: Lambretta67
Main scooter: Lambretta L.I. 200 special
Location: Newbury
Contact:

Thu Jun 25, 2020 10:26 pm

I haven't checked the float needle yet. I changed it about 5years ago. It might just be coincidence that scoot ran fine when I changed the atomizer for a jetex one last time it played up. Seems strange its doing the same thing 6000 miles later..plug is a very dark brown.

User avatar
EddieStone
registered user
Posts: 413
Joined: Mon Aug 17, 2015 4:13 pm
Main scooter: Lambretta Li 150
Contact:

Thu Jun 25, 2020 10:32 pm

Do a bit of research or call a decent shop to make sure you get the right one. There are two lengths possible, I think, and different tip materials.

Lambretta67
registered user
Posts: 233
Joined: Fri Mar 30, 2018 5:02 pm
ebay user ID: Lambretta67
Main scooter: Lambretta L.I. 200 special
Location: Newbury
Contact:

Thu Jun 25, 2020 10:37 pm

Black one was in the carb when I bought it. I fitted a red tip one I bought from scooter restorations.

Daggs
registered user
Posts: 706
Joined: Wed Jan 07, 2009 1:23 pm
Location: Addington Kent
Contact:

Fri Jun 26, 2020 7:30 am

If it has happened during the recent hot weather, this could be the answer.
I don't agree with the idea a leaky float valve would cause this.

User avatar
coaster
registered user
Posts: 3103
Joined: Wed Jan 07, 2009 12:35 pm
Location: London and Norfolk
Contact:

Fri Jun 26, 2020 8:37 am

It could easily be due to the warm weather as it will run rich when the air temp goes up.

Lambretta67
registered user
Posts: 233
Joined: Fri Mar 30, 2018 5:02 pm
ebay user ID: Lambretta67
Main scooter: Lambretta L.I. 200 special
Location: Newbury
Contact:

Fri Jun 26, 2020 8:49 am

You might be right. it started yesterday when I was riding back from work. The temperature was in the 30s. Was fine when I road to work in the morning at 5am when the air was cooler

Post Reply Previous topicNext topic
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest