DC System and sip speedo issues

Anything related to Lambrettas... ask tech questions, post helpful info, or just read and learn.
wintermod65
registered user
Posts: 102
Joined: Mon Apr 02, 2018 8:06 pm
Main scooter: winter model
Location: Suffolk
Contact:

Sat Jul 13, 2019 10:25 pm

hi
having the sip speedo cut out issue on a dc system
scootronics dc stator ,bgm flywheel , wassel regulator , mb wiring loom scootopia switches , all new less than 200 m on gt 240 motor

speedo comes on with daylight/main lights position on ignition switch .

Sip 5AH battery , which now doesnt seem to hold charge always been kept on optimate battery charger .
am getting 12.95v dc across battery engine not running

and about 14 to 17.9v with engine running from tickover to revving wonder if the upper reading is too high and frying the battery or if ok why does speedo cut out if needs 12-16 v

speedo comes on if engine runs then goes off if press brake light / horn

any thoughts or similar experiences with DC system be helpful
cheers

firekdp
registered user
Posts: 737
Joined: Wed Jan 07, 2009 12:02 pm
Location: Fareham, Hants
Contact:

Sun Jul 14, 2019 10:39 am

Yes, 17.9v will damage the battery, looks like you have a dodgy rectifier. Was it a genuine Wassel?
To test the battery, hook up your voltmeter to the battery, switch on the lights and hit the brake light and see what effect this has on the battery voltage.

wintermod65
registered user
Posts: 102
Joined: Mon Apr 02, 2018 8:06 pm
Main scooter: winter model
Location: Suffolk
Contact:

Sun Jul 14, 2019 1:51 pm

regulator was bought from MB scooters , so hope was genuine .

lights were dim when switch on even after charging battery will get reading on meter .

went for ride out today speedo led display cut out even while doing steady 40-45 mph without operating brake light or horn , turned key back to ignition only position then to daylights position an speedo resets .
was going to get new regulator as precaution saw video on youtube guy with vespa auto poss lx says max charging voltage should be 16v so mine seemed high if the lambretta dc system should be abot same

firekdp
registered user
Posts: 737
Joined: Wed Jan 07, 2009 12:02 pm
Location: Fareham, Hants
Contact:

Sun Jul 14, 2019 5:36 pm

wintermod65 wrote:
Sun Jul 14, 2019 1:51 pm
regulator was bought from MB scooters , so hope was genuine .
I see he advertises them as Wassel/podronics/BGM/scootronics! So you'll have to ask him which one it is, as it can only be one of them. If it is the type with one yellow cut off it's probably the 3 phase one repackaged as BGM.
For good battery life, I wouldn't want the reg/rec output to go over 14.7v.

wintermod65
registered user
Posts: 102
Joined: Mon Apr 02, 2018 8:06 pm
Main scooter: winter model
Location: Suffolk
Contact:

Thu Jul 18, 2019 10:15 pm

have gone for an anthony tambs scootronics Dc reg to replace the failed wassel/bgm one arrived in a day and answered my questions out of office hours so all good so far .

have to replace battery and am thinking of going for the larger SIP 9AH battery hoping move battery location from inside standard toolbox to an underpanel carrier either the TD customs or K2 customs versions for S2's.

once get battery charging all sorted can look to get Sip speedo working properly ,if thats possible !!

User avatar
ForemanBob
registered user
Posts: 246
Joined: Thu Sep 17, 2009 7:27 pm
Main scooter: GP RT230
Location: Isle of Naboombu
Contact:

Sat Jul 20, 2019 12:43 pm

You are simply suffering from low voltage... I dont like optimates... they eventually overcharge the battery.

Change the battery for a new one, run the scooter regularly and you shouldnt have any issues...

wintermod65
registered user
Posts: 102
Joined: Mon Apr 02, 2018 8:06 pm
Main scooter: winter model
Location: Suffolk
Contact:

Thu Jul 25, 2019 10:13 am

low voltage ? im getting 17.9 v dc across battery at around 3k rpm

what are you meant to see as most people ive contacted inc Anthony tambs state this is too high and will fry the battery

the speedo issue has happened since picking scooter up from restoration and prior to me me using the optimate on it , ive not had issues with batteries before when using it on a GTS for 2 years and my old Fireblade which had 1 battery in 10 years mines an optimate 4 but keep an eye on things

Post Reply Previous topicNext topic
  • Information
  • Who is online

    Users browsing this forum: No registered users and 11 guests