Avanti bogging down

Anything related to Lambrettas... ask tech questions, post helpful info, or just read and learn.
whonatic
registered user
Posts: 162
Joined: Sat Mar 07, 2009 7:32 pm
Contact:

Fri Apr 14, 2017 9:03 pm

I've got this problem on an Avanti I rebuilt for my mate. We changed the crank and finally cured (after several attempts) the drive side oil seal failing with a rimini drive side plate.

But now, it really bogs down in first and 2nd and you have to really rev and slip the clutch to get away. Reminds of when I had a Rapido that behaved the same, it was something to do with transfers being too large on that, a design fault. BUT! This ran well before and crank is the same lentgh Rod as before! It's not jetting, it's not cables wrong way round, Antony tambs reconditioned the stator, and it flies in 3rd and 4th!!

I'm out of ideas and it's on my head to sort it !

User avatar
drunkmunkey6969
Moderator
Posts: 4252
Joined: Sun Jan 04, 2009 1:42 pm
ebay user ID: sc00terotica
Main scooter: '69 Lambretta GP
Location: North Yorkshire
Contact:

Fri Apr 14, 2017 10:07 pm

Inlet timing is to high...?


Sent from my iPhone using Tapatalk

whonatic
registered user
Posts: 162
Joined: Sat Mar 07, 2009 7:32 pm
Contact:

Fri Apr 14, 2017 10:22 pm

drunkmunkey6969 wrote:Inlet timing is to high...?


Sent from my iPhone using Tapatalk
But that hasn't changed as crank of equal dimensions has gone back in with same piston?

Darrell Taylor
Dealer
Posts: 818
Joined: Wed Apr 06, 2011 8:43 am
Main scooter: LAMBRETTA
Location: Doncaster
Contact:

Fri Apr 14, 2017 11:01 pm

if drive side was leaking before then will have been leaner , now its cured the jetting will be richer ,too rich bottom end but not as much at top end as its performing well there what carb and jetting settings you running ,also new stator ,,has it been strobed up or just refitted in previous position ?
feel free to use this link to contact me on facebook and like it(if u like it)
https://www.facebook.com/pages/Taylor-T ... 8819767924

mick1
registered user
Posts: 1527
Joined: Sun Dec 04, 2011 7:43 pm
ebay user ID: saxonleaf
Main scooter: Li Avanti 225
Location: York
Contact:

Sat Apr 15, 2017 7:49 am

What's your full spec' ?

I had a "small" issue with the scooter bogging at low rev's. Fitting a MTech overcame the problem.

Gearing and exhaust could also be a factor

User avatar
OAP
Dealer
Posts: 189
Joined: Wed Mar 17, 2010 10:16 am
Contact:

Sat Apr 15, 2017 8:56 am

As Mick said, post FULL spec also all jet sizes & make sure your choke is working (closing), I'm kin busy today but you can phone me. 07951952768 Ron

whonatic
registered user
Posts: 162
Joined: Sat Mar 07, 2009 7:32 pm
Contact:

Sat Apr 15, 2017 9:18 am

Darrell Taylor wrote:if drive side was leaking before then will have been leaner , now its cured the jetting will be richer ,too rich bottom end but not as much at top end as its performing well there what carb and jetting settings you running ,also new stator ,,has it been strobed up or just refitted in previous position ?
Running pacemaker gearbox, 30mm phbh - 55 pilot, 122 main, av266, x7 top clip (weakest) , BGM box pipe

User avatar
OAP
Dealer
Posts: 189
Joined: Wed Mar 17, 2010 10:16 am
Contact:

Sat Apr 15, 2017 9:31 am

crank 58 x 107? what ignition is fitted & set at what? and as Darrell was it strobed?

User avatar
OAP
Dealer
Posts: 189
Joined: Wed Mar 17, 2010 10:16 am
Contact:

Sat Apr 15, 2017 9:35 am

Also how old is the Atomiser & needle, are they worn?

User avatar
OAP
Dealer
Posts: 189
Joined: Wed Mar 17, 2010 10:16 am
Contact:

Sat Apr 15, 2017 9:36 am

easier to phone me!!

Post Reply Previous topicNext topic
  • Information
  • Who is online

    Users browsing this forum: No registered users and 7 guests