Battery Problems

FREE tuning and maintenance info, plus links to our original tuning pages that started it all off.
dippyrider
Posts: 4
Joined: Sat Mar 07, 2020 4:59 pm
ebay user ID: dippyrider
Main scooter: Lambretta LI150
Contact:

Sat Jun 20, 2020 7:32 pm

I have a LI150 Series 2. I have upgraded to 12v and fitted a Casatronic Ducati Ignition System which works a treat.
I have connected the wiring as per their instructions and fitted a 12V Battery.
I have found that the Battery is always live and as such drains quickly and gets quite hot.

Any suggestions???

firekdp
registered user
Posts: 701
Joined: Wed Jan 07, 2009 12:02 pm
Location: Fareham, Hants
Contact:

Sat Jun 20, 2020 9:08 pm

If it is losing charge and getting hot whilst not in use, you have a very large load being drawn somewhere.
If nothing is switched on, check your wiring!

firekdp
registered user
Posts: 701
Joined: Wed Jan 07, 2009 12:02 pm
Location: Fareham, Hants
Contact:

Sun Jun 21, 2020 7:33 am

If you've wired it as per instructions using a junction box, make sure that it is an AC type, to keep your AC and DC circuits separate. A DC one will short your battery through the stator!
Also check the green pair are where they say they are, I've had one where the green dot was in the wrong place leading to a short.

Grumpy225
registered user
Posts: 630
Joined: Sat Nov 24, 2012 7:59 am
ebay user ID: Grumpy225
Main scooter: Gori200, rt195, ld150,rb20
Location: Bakersfield, CA
Contact:

Tue Jun 23, 2020 6:53 pm

firekdp wrote:
Sun Jun 21, 2020 7:33 am
..., I've had one where the green dot was in the wrong place leading to a short.
I’ve had a couple like that. Just pop the back off and have a look at how it’s set up.

Post Reply Previous topicNext topic
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest